16 May 2018

Selling Platform users – do you have the right IE version?

We recently realized that there are many users of Selling Platform Classic and Connect who have a TLS 1.2 compliant Operating System but not the latest Internet Explorer version as we recommend.

What’s the impact?

You won’t be able to access Selling Platform Classic or Connect if you are using an older version of Internet Explorer.

What to do?

This problem can easily be resolved by activating the support in the browser’s setting for Internet Explorer 8 and 9.

See also previous information published at Amadeus Service Hub here.

Updated: 16 May, 2018